Table Of Contents

Welcome to WISE-FTP! ...................................................................................................................... 1
What's new ........................................................................................................................................ 2
   What's new in version 9? ................................................................................................................ 2
   What's new in version 8? ................................................................................................................ 2
   What's new in version 7? ................................................................................................................ 2
   What's new in version 6? ............................................................................................................... 3
   What's new in version 5? ................................................................................................................ 4
   What's new in version 4? ................................................................................................................ 4
   What's new in version 3? ................................................................................................................ 6
   What's new in version 2? ................................................................................................................ 7
Basics ................................................................................................................................................... 8
   Features .......................................................................................................................................... 8
   What is FTP? .................................................................................................................................... 9
   What is SFTP? .................................................................................................................................. 9
   What is FTPS (FTP over SSL)? ..................................................................................................... 10
Fingerprints....................................................................................................................................... 10
   What is an FTP server? .................................................................................................................. 11
   What is an IP address? ................................................................................................................... 11
Getting started ..................................................................................................................................... 12
   Main window ................................................................................................................................ 12
   Ordering and unlocking WISE-FTP ............................................................................................ 12
   Update Manager ............................................................................................................................ 12
Working with WISE-FTP .................................................................................................................. 13
   Manage files and folders ............................................................................................................... 21
   Manage sites ................................................................................................................................ 27
   Favorites ........................................................................................................................................ 29
   Macros .......................................................................................................................................... 30
   WISE-FTP Task Planner ............................................................................................................... 31
Settings and Commands .................................................................................................................. 34
Meaning of reply codes .................................................................................................................... 43
   Reply codes ................................................................................................................................ 43
   1xx - Positive reply ...................................................................................................................... 43
   2xx - Successful operation ........................................................................................................... 43
   3xx - Positive interim reply ......................................................................................................... 44
   4xx - Transient negative reply ................................................................................................... 44
   5xx - Permanent negative reply ................................................................................................. 44
   Frequent reply codes and causes ................................................................................................. 45
FTP commands .................................................................................................................................. 46
   Supported FTP commands (overview) ......................................................................................... 46
   FTP command: CHMOD ............................................................................................................... 46
   FTP command: CWD ..................................................................................................................... 46
   FTP command: HELP .................................................................................................................... 46
   FTP command: LIST ...................................................................................................................... 47
   FTP command: NLST .................................................................................................................... 47
   FTP command: PWD ..................................................................................................................... 47
   FTP command: QUOTE ............................................................................................................... 47
   FTP command: RETR .................................................................................................................... 47
   FTP command: SITE ..................................................................................................................... 47
   FTP command: STOR .................................................................................................................... 47
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTP command: SYST</td>
<td>47</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>48</td>
</tr>
<tr>
<td>Getting help</td>
<td>48</td>
</tr>
<tr>
<td>Connection problems</td>
<td>48</td>
</tr>
<tr>
<td>Problems during file transfer</td>
<td>49</td>
</tr>
<tr>
<td>Symlinks</td>
<td>50</td>
</tr>
<tr>
<td>Index</td>
<td>51</td>
</tr>
</tbody>
</table>
**Welcome to WISE-FTP!**

**WISE-FTP** is a powerful FTP client - an application that enables you to connect to any [FTP server](#) and download or upload files and directories. **WISE-FTP** can connect to any valid FTP site and it is not bound to a specific server operating system. It supports a wide range of operating systems, including Windows, OS/2 and UNIX standards. To use **WISE-FTP** you need no in-depth knowledge of how the [FTP](#) protocol works. Its comprehensive functionality makes **WISE-FTP** an ideal tool for webmasters who regularly update their sites or have to perform file transfers.

If you have no experience with using FTP clients or are new to working with the Internet, the following topics will help you to find a start:

- [What is FTP?](#)
- [Main window](#)
- [Connect to FTP site](#)
- [Transfer files or directories](#)
**What's new**

**What's new in version 9?**

- New advanced user interface is **fully compatible with Windows 10** and includes a comprehensive set of new styles.
- The **Task Planner** was redesigned into a Windows Service; now it works in background, does not require a user to be logged on, and consumes less system resources.
- New function *Upload optimized for Web* allows to significantly reduce the size of HTML, CSS and similar files before uploading them to a hosting server.
- Upload, download and deletion of large amounts of files were optimized for the **best performance ever**.
- Numerous improvements and optimizations in all programs areas.

**What's new in version 8?**

- Support of **IPv6** protocol was implemented.
- **Offline mode** with automatic reconnect was introduced to handle server disconnections more user friendly.
- The **Task Planner** was further extended.
- **Synchronization** methods were optimized in the main program and Task Planner.
- Local **system shell controls** were updated and optimized for the latest versions of Windows.
- Numerous other user interface improvements and optimizations were implemented.

**What's new in version 7?**

- **Faster data transfers:** **WISE-FTP** will now start to transfer data, while it is still creating a list of all files to be transferred in the background. Thus, the transfer of huge amounts of data will be realized even faster.
- **Synchronized Browsing:** This new feature allows you to change the directories on your PC and the FTP server simultaneously if the directory structure is identical. If you change to another directory on one side, **WISE-FTP** will automatically update the view on the other side.
• **New dialog for already existing files:** If a file which is currently being transferred already exists on the target system, a new dialog field will allow you to choose from several options to decide how to proceed with that file.

• **Change up-/download priority:** For files which are already in the transfer queue can now set a lower or higher priority. Thus, you can move single files to the top or on the bottom of the transfer list if you are transferring a huge number of files.

• **Improved transfer statistics:** Detailed status information will now show you exactly how many files have already been transferred and how many are still in the transfer queue.

• **Improved Drag & Drop:** You can drag files and directories to the desired target position and drop them there.

• **Improved editing of files on the server:** Edit files on the server now even more comfortably in the integrated editor.

• **Improved Site Manager:** Several improvements in the Site Manager make managing the FTP profiles even easier.

• An option **Program Start Mode** was added which, e. g., allows you to reopen the last used connections when starting the program.

• The program was redesigned with full **Unicode support**.

• **Implicit SSL** and an **improved support** of secure transfers via SSL/TSL were implemented.

• **Automatic detection** of a server's supported features during the connecting process.

• Improved working with Unicode-capable servers.

• The possibility to preserve the file time after uploading on servers with support of MFTM command was added.

• New option to change file names during transfer to upper or lower case.

• Numerous improvements of the program functions and the user interface.

**What's new in version 6?**

• **Increased speed:** WISE-FTP 6 has been completely revised so that transfers can now be carried out even faster.

• **Optimized for Windows Vista:** WISE-FTP 6 works optimally with Windows Vista while naturally also staying compatible with previous Windows versions.

• **Improved Task Planner:** The Task Planner has been completely revised which makes this module now even more reliable and working with it more comfortable.
What's new

- **Numerous optimizations and new features**: Many updates and add-ons, from the new favorites bar to the revised notes regarding server messages, complete the new version.
- **Improved optics**: The WISE-FTP 6 interface has been redesigned so that working with your favorite FTP client is now an optical highlight as well.

**What's new in version 5?**

- **More security**: Supports the cryptographic protocols SSL (Secure Sockets Layer) and TLS (Transport Layer Security) for secure data transfer and communication with FTP servers.
- **Macro functionality**: Enables you to record frequently performed actions and run them subsequently as often as you wish.
- **Fast and user-friendly transfer**: First compress files directly from WISE-FTP and upload them. Alternatively, you can split large files for fast upload/download.
- **Even more security**: Provides numerous encryption algorithms (Rijndael 128, 192, and 256 bits, BlowFish, TripleDES, as well as PGP) for the encryption of files to be transferred to or from the FTP server.
- **Optional special user interface** for improved handling of simultaneous connections: If you are working simultaneously with several FTP servers, each server can now be represented in the FTP server window as a separate tab.
- **Direct transfer** from FTP server to FTP server. The new multi-server interface supports transfer with drag & drop.
- Enhanced support of **customized commands**: Integrate your customized commands in the menu, assign keys to commands and use macro parameters.
- **Improved support of FTP servers** that do not work with standard response types.
- Better integration of main program and **task planner** for the user-friendly scheduling of repeat transfers.
- Various other improvements and optimizations.

**What's new in version 4?**

- **New, improved user interface**: The main window of the program now has a more flexible and up-to-date interface. You can use drag-and-dock to rearrange the layout to suit your preference, hide panels or have them float. The application supports several UI
themes (skins), which allows you to configure the appearance of the interface in accordance with your personal taste.

- **Integrated compression/decompression:** Wise-FTP 4 can automatically compress files before they are uploaded and decompress them after they have been downloaded using different archive formats (.zip, .z, .cab, .gz, .tar.gz, etc.).

- **Server Statistics/Log:** You may configure each server profile to keep a continuous log and collect usage data, which can be displayed in a special statistics window.

- **Real file preview:** The integrated Preview/Editor can now display not only html/text files, but virtually every type of file normally stored on a web server; text, scripts, images, PDF documents, MS Office documents, contents of ZIP files and many others.

- **Improved Site Manager:** In Wise-FTP 4, the Site Manager stores and displays two sets of FTP profiles: "My FTP Servers" and "Common FTP Servers". The first set is stored in a personal folder, giving each user on a shared PC a personal set of FTP servers. The second set allows several users sharing a single PC to share their commonly used FTP profiles.

- **Mask support:** Wise-FTP 4 supports the use of file name and extension masks; for example, you may set filters for the remote or local system to display only *.html files, or not to display *.bak files. Many commands also support the masks: "Download by mask", "Upload by mask", "Set attributes with mask", and others.

- **Display filter for better overview:** If you are working on remote servers storing large numbers of files, you will greatly appreciate the new display filter. Specify the file types to be displayed to reduce the number of files displayed accordingly.

- **Transfers Queue:** Besides transferring immediately, you can add transfers (downloads or uploads) to the Queue; the actual time of transfer of queued items will be at a time convenient for you.

- **Improved Task Planner:** Interaction between the Task Planner and main program is better integrated. You may schedule transfers directly from the main program. The Task Planner now supports a new task type; namely, "Synchronization" between local and remote directories.

- **New "Synchronization" Task:** The Task Planner now also offers the new task type "Synchronization" allowing you to synchronize local with remote directories.

- **Backup/Restore functions:** Try the easy-to-use "Backup" and "Restore" commands to ensure you never lose your important data (FTP servers connection data and "Favorites").
What's new

- Other improvements:
  - Remote system displays system icons and supports different view modes.
  - Support of Port Ranges for working with NAT routers.
  - Unterstützung des Befehls XCRC – einige FTP-Server unterstützen diese Option zur Prüfung eines Transfers, so dass sichergestellt wird, dass kein Fehler bei der Übertragung stattgefunden hat.
  - Drag-and-Drop using the right mouse button provides a context menu with different options.
  - Re-Login to server enables reconnecting to a server using a different user name.
  - Support of Advanced/Simple log types.
  - Better explanation of WinSock errors in the Advanced Log window.
  - Task Planner can send e-mails about the results of scheduled task operations.
  - Ability to limit transfer speed for uploads and downloads.
  - Automatic Dial-Up and disconnection for users with modem connections.
  - Feature that allows uploading a file with a different name.
  - Upload files using the command line.
  - "Symlinks" handling on UNIX servers.
  - Quick access to "My FTP Servers" via a drop-down menu on the Connect button.
  - Supports transfer of files larger than 2 GBytes.

What's new in version 3?

That's new in version 3:
- New, improved user interface
- Secure authentication and file transfer (SFTP)
- SOCKS proxy support
- Clipboard monitoring
- Configuration wizard that opens the first time the program starts
- Ability to assign short-cuts for operations
- Adjustable toolbar icon size
- Improvement of the local Explorer
- Improvement of remote files editing
- Integrated HTML Editor
- Improvement of the text editor
What's new in version 2?

The revised WISE-FTP version 2 has the following new features:

- Wise-FTP Scheduler: use this new convenient tool to schedule your transfers
- Integrated Windows Explorer
- Synchronization of directories and subdirectories between your local system and the FTP server
- Move files and directories on the FTP server directly, without first downloading them to the local system
- Remember transfer tasks! save recurring transfers and reload them later with only few mouse clicks
- Search for files on the FTP server
- Create and organize favorites
- Edit files on the FTP server directly (use an external or internal editor and then upload the revised file)
- Run file operations (create, delete, etc. files/directories) on your local system
- Sounds for different actions (configurable)
- Search and find log files
- More information in the transfer window (transfer time, speed etc.)
- Icons for files
- Multiple selection in the local system directory tree and the FTP server
- Editable path box for faster navigation
- Add file name during quick connections, to download only one file
- Account name for server configuration
- Upload/download files with masks
- Load transfer tasks from a file
- Miscellaneous bug fixes and many internal enhancements


Basics

Features

WISE-FTP's basic features include:

- Ability to connect to any FTP server.
- Ability to move or copy files or directories from your local system to the remote server and vice versa.
- Saving connection settings, so that frequently used FTP servers are accessible with just one mouse click.

In addition to this basic functionality, WISE-FTP provides many powerful functions you need for your everyday work. These are, for example:

- A task planner for time-controlled, automated transfer operations.
- Windows Explorer integration enables you to establish connections via Windows Explorer.
- Secure authentication and file transfer through STFP or the SSL/TLS protocol.
- Multiple connections to one or more remote servers and transfer of files from one remote server to one or more other remote servers in the background.
- Macro recorder for recording actions and repeating them as many times as desired.
- Optional encryption (Rijndael 128, 192, and 256 Bits, BlowFish, TripleDES, as well as PGP) and compression of files before or after transfer for improved security and speed.
- Synchronizing contents of directories on your local and remote system.
- Integrated HTML editor allows files to be edited directly on the remote server.
- Quick view of files using the integrated file viewer or the designated Windows application.
- User-defined hot keys for various program actions.
- Ability to move files and directories directly between remote servers - without first downloading them to your local system.
- Ability to save transfer tasks so that periodic transfers can be re-loaded at a later point in time.
- Ability to perform a file search on the remote system.
- Creating and organizing favorites.
- Upload/download of files using a mask.
- Configurable sounds for various program actions.
- Numerous other program functions described in this document.
NOTE: For context-sensitive help, hover the mouse pointer over any program menu item and press F1.

What is FTP?

The **File Transfer Protocol (FTP)** is a network protocol specified in the RFC 959 which allows file transfer via TCP/IP networks. It is used to transfer files from server to client (download), from client to server (upload) or between two servers, controlled by the client. In addition, FTP allows creating directories and reading directory contents as well as renaming or deleting directories and files.

FTP uses separate connections for control and transfer: An FTP session is initiated by the client's establishing a TCP connection to the control port of the server (the default port for this being port 21). Via this connection, commands are sent to the server. The server replies to each command with a **status code**, which is often appended with an explanatory text. Most commands, however, will only be accepted after successful authentication. Separate TCP connections are used to send and receive files and to transfer directory listings for each operation. FTP knows two modes for establishing those connections: **active mode** and passive mode.

Many FTP servers, in particular servers at colleges or universities and mirror servers, offer what is called "anonymous FTP": In addition to log-ins under real user accounts, they also allow users to log in under a special user account, "anonymous" and/or "ftp", for which no password is needed or any password can be entered. However, "netiquette" requires the user to enter his valid e-mail address as password when using anonymous FTP.

Since FTP is a text-based protocol, data as well as authentication information is transferred as plain text without encryption. Thus, FTP should not be used for confidential data and file transfers that exceed the range of anonymous FTP use. Alternative solutions addressing this issue include, among others, Secure File Transfer Protocol (Secure FTP), Secure Copy (SCP), and SSH File Transfer Protocol (SFTP).

What is SFTP?

The **SSH File Transfer Protocol** or SFTP is a network protocol that provides file transfer and manipulation functionality over any reliable data stream. In WISE-FTP it is used with the SSH-2 protocol to provide secure file transfer, but is intended to be usable with other protocols as well. The SFTP Protocol provides secure file transfer functionality over any reliable data stream. It is the standard file transfer protocol used with the SSH2 protocol. WISE-FTP implements the client side of this protocol, which is reliable and easy to use.

The SFTP protocol is primarily designed to provide file transfers, but is can also be used for more general file system access on the remote server. The SFTP protocol runs on a secure channel, which means that passwords and file information are not exposed to the network in plain text.

WISE-FTP not only supports the most important PutFile (for file uploading) and GetFile (for file downloading) methods, but also:

- MakeDir and RemoveDir to create and delete directories
- DeleteFile to delete files on the server
- ListItems to list files in directories or on the remote server
- GetAttributes and SetAttributes to retrieve and set attributes for a file or directory
- Resume to resume broken transfers
• Blocking mode to execute methods and wait until they are completed
• Password and PrivateKey properties to determine the type of authentication used by the server
• ASCII and binary file transfers to handle different types of data
• Executed operation is deleted when the executed method is complete

**WISE-FTP** works with all OpenSSH versions and SSH (from SSH Communications Security Corp.), which are the most common protocols used on present day servers, but it has also been tested with others. Although different server implementations handle some SFTP features in different ways (for example, some add "/" to the end of each directory name), **WISE-FTP** has no problems with these variations.

**NOTE:** A common misconception is that SFTP is simply FTP run over SSH; in fact it is a new protocol designed from the ground up by the IETF working group. It can also be easily confused with Simple File Transfer Protocol (SFTP).

**What is FTPS (FTP over SSL)?**

FTPS (commonly referred to as FTP/SSL) is a name used to encompass a number of ways in which FTP software can perform secure file transfers. Each way involves the use of a SSL/TLS layer below the standard FTP protocol to encrypt the control and/or data channels.

**Explicit**
In explicit mode (also known as FTPES), an FTPS client must "explicitly request" security from an FTPS server and then step-up to a mutually agreed encryption method. If a client does not request security, the FTPS server can either allow the client to continue insecure or refuse the connection.

**Implicit**
Negotiation is not allowed with implicit FTPS configurations. A client is immediately expected to challenge the FTPS server with a TLS/SSL **Client Hello message**. If such a message is not received by the FTPS server, the server will drop the connection.

To establish an FTPS (implicit TLS/SSL) or FTPES (explicit TLS/SSL) connection with an FTP site using **WISE-FTP**, select the connection type **FTPS** or **FTPES** in the Site Manager dialog box and define the settings via the **Advanced** button to select an **Authentication method**.

**Fingerprints**

Since SSH architecture does not recognize certificates and has no other way to check whether the remote server is really the server you are expecting to be connected to, your decision to accept the connection or not is based solely on trust.

You normally use SSH as follows: if you have connected to a remote server once and you are sure that this is the server you wish to connect to, you should save fingerprint information locally. Every time you reconnect, you should check whether the fingerprint data matches the information you stored to make sure that nobody is "in between". Fingerprint information is unique for different servers and is generated by the server's private key.
What is an FTP server?

An FTP site is based on a server program that runs on a "host" computer. Such a host is a networked computer which can run one or more servers. This is why host computers are often referred to as servers in colloquial language.

A server is a program waiting to be contacted by a client program such as WISE-FTP in order to exchange information. This communication is organized according to the so-called client/server system. The rules determining the format and meaning of the information exchanged between server and client are called the "protocol".

Many companies and organizations maintain FTP servers so that the public can, for example, download shareware versions of their software.

If you are logged onto such a server and you cannot find what you are looking for, search for files with names such as readme, readme.txt, index, or 00index. Such files usually contain important information about the files available on the server. FTP sites are usually public sites. You may simply log in with the user name anonymous and enter your e-mail address as your password. Password-protected servers allow users to upload files themselves for use by others. This is how websites can easily be updated and expanded.

What is an IP address?

An IP address is a unique identifier that defines the location of a computer on the Internet. It also includes information about the service provider and the location of the server. There are two types of IPs currently in use: the old IPv4 and the new IPv6.

IPv4 addresses are 32-bit addresses composed of four separate numbers from 1 to 255, separated by dots (.)
IPv6 addresses are 128 bit addresses composed of blocks of numbers and letters, separated by a colon (:)
Since most users find it easier to remember names than numbers, IP addresses are usually mapped to a special host name.

Any address starting with http:// or ftp:// is simply a masked IP address. WISE-FTP accepts IP addresses as well as host names.
Getting started

Main window

All important wise-ftp features can be accessed directly from the main window via the toolbar. The main window is divided into four sections:

- **FTP Log** (top),
- Local System (center left),
- Remote System (center right),
- Transfer Progress (bottom).

Ordering and unlocking WISE-FTP

To unlock WISE-FTP proceed as follows:

**If you posses no valid license (unlock code) for your version yet:**
1. Click on Help/Purchase... to open the Order and unlock WISE-FTP dialog box.
2. Click Web server (Step 1). You will be directed to the ordering page, where you can order WISE-FTP.
3. After successfully ordering WISE-FTP, you will receive an e-mail with your unlock code. (This will happen within seconds if you pay via credit card.)
4. As soon as you have received your unlock code vial e-mail, click on Unlock Now (Step 2) in the Order and unlock WISE-FTP dialog box, and follow the instructions by the Wizard to unlock the program as a full version.

**If you already posses a valid license (unlock code) for your version:**
1. Click on Help/Purchase... to open the Order and unlock WISE-FTP dialog box.
2. Click on Unlock Now (Step 2).
3. Follow the instructions by the Wizard to unlock the program as a full version.

Update Manager

The Update Manager enables you to keep your software up-to-date at all times! Update Manager automatically checks via the Internet whether a newer version of WISE-FTP is available. Use this command regularly to ensure that you are always working with the most current version. If you have problems, make sure no antivirus software or firewalls that may stop Update Manager from connecting to the Internet are active. If the problems persist, download product updates manually from the WISE-FTP website. From the File menu, select Update Manager to start the update.

**NOTE:** Only free updates will be installed.
Working with WISE-FTP

Connect to FTP site

To connect to an FTP site, click the Connect button. The Site Manager dialog box will open, where you can enter a user name and password to log onto an FTP site.
For servers that allow anonymous login, use anonymous as your user name and your e-mail address as your password.
To log onto private sites that support operations such as file upload, you need a predefined ID/password combination and sometimes a special account number. Such sites are normally used to share corporate information with other users or to manage websites. Contact your web space provider for the necessary login information.
Before connecting, create a new server profile.
To use an existing connection click Connect.
After having created an FTP site, you can now connect to a server. To do so, proceed as follows:
1. Click the Connect button, or select Connect from the File menu.
2. In the Site Manager dialog box that opens, select an existing server or create a new FTP site.
3. Then click Connect to establish the connection to the selected server.
4. Details about your connection will appear in the FTP Log window.
Learn more about how to transfer files or folders.

Create new FTP site

To create a new site proceed as follows:
1. Click Connect in the tool bar (a green 'turn on' icon) or choose Site Manager from the Tools menu to open the Site Manager dialog box.
2. Click New Site.
3. Enter a unique name for the respective site in the Profile name field.
4. Then enter a Server address and Port. The server address has to be entered without "www." and http:", for example mywebsite.com. The standard port for FTP is "21" or "ftp".
5. If you require an account number for your FTP account, enter the number in the Account field. In most cases, however, you can leave this field blank.
6. Enter your user name in the Username field as given by your provider. If you wish to log in as a guest, enter anonymous. Please note that the user name is usually case sensitive.
7. Enter your password in the Password fields as given by your provider. This entry is case-sensitive, too. If you have chosen anonymous as user name, simply enter your e-mail address in this field.
8. In the **Connection type** field, you can choose either **FTP**, **SFTP**, **FTPS** or **FTPES**. If you choose one of the latter, the **Advanced...** button allows you to choose an SFTP **Authentication Method** or the **SSL settings**.

9. In the **Home directory** field, you may (optionally) enter the path of a home directory on the **FTP server**, e.g. the root directory of your website.

10. In the **Local directory** field, you may (optionally) enter the path of a local home directory. This folder will be displayed when connecting to this server.

11. Check the **Synchronized browsing** box if you want to synchronize the folders you are currently opening on the local system and the remote system. For example: When you have the same folders structure of remote system and local system and switch to another folder on the local system, the according folder on the remote system will automatically be opened.

   **Note**: Please ensure to enter a **Home directory** and a **Local directory** which have the same directory structure to be able to use Synchronized Browsing.

12. Enable the **Passive** checkbox to allow **passive transfer**.

13. If you want to store a **log** and or **statistics** about connections, downloads etc. activate the according option here. You can see both statistics and the log by clicking the according option in the tool bar above this connection dialog.

Click the **Additional** tab if you wish to define optional further settings:

1. **Server Class**: Select the class of your server. If you select **Auto-Detect** it will be chosen automatically.

2. **Linux Directory**: You may optionally enter a Linux directory.

3. **LIST Parameter(s)**: If the LIST parameter of your FTP server is not "-al", you can adjust the entry in this field accordingly.

4. **Use global speed limits**: To limit the speed of transfer using different options from those defined under **Options/Connection and Transfer**, disable the **Use global speed limits** checkbox and enter the respective parameters.

5. The **Use general proxy configuration** option allows you to define your proxy settings. Disable the **Use general proxy configuration** checkbox to configure specific settings for this FTP site. When this checkbox is enabled, the settings defined under **Options > Proxy Settings** will be used for this FTP site.

6. **Time Offset**: Use this option to adjust the server’s time for better synchronization between local and remote systems.

7. **Comments**: You may enter any description or comment in this field.
**Authentication method selection**

You can select an authentication method to ensure that you are establishing a connection to the correct server, provided you have chosen SFTP as the connection type.

- Click the **Tools** menu and select **Site Manager** to open the **Site Manager** dialog window.
- Select SFTP as the connection type and click on **Advanced** to open the **Authentication Method** dialog window.
- You can choose **Password** and/or a **Public/private key**.
- Select **Both** if you want to use both methods.
- If you select **Password**, your FTP password will be used.
- If you select **Public/Private key**, you can select a key file below and enter a password, with which this key file will be encrypted.
- Click **OK** to close the dialog window.

**SSL Settings**

**WISE-FTP** supports **SSL** (Secure Sockets Layer) and **TLS** (Transport Layer Security). These are encryption protocols for secure communication and data transfer from and to FTP servers.

**FTPS (implicit TLS/SSL)**

- Check the option **Verify server certificate** if you want to check the server-sided certificate before connecting.
- Below, you can select a client **certificate** by clicking the button on the right side.
- In addition, select a **private key file** and enter a **password** for encrypting that key file.
- Click **OK** to close the dialog window.

**FTPES (explicit TLS/SSL)**

- Check the option **Verify server certificate** if you want to check the server-sided certificate before connecting.
- Below, you can select a client **certificate** by clicking the button on the right side.
- In addition, select a **private key file** and enter a **password** for encrypting that key file.
- Furthermore, you have to decide which FTP command (**AUTH type**) you want to use: AUTH SSL or AUTH TLS. Please make sure which one your server supports.
- Click **OK** to close the dialog window.
Certificate Information

WISE-FTP supports SSL (Secure Sockets Layer) and TLS (Transport Layer Security). These are encryption protocols for secure communication and data transfer from and to FTP servers. For the encryption and decryption of data transfers to secure FTP servers, you must use a certificate.

SSH key pair generator

You can create the key for an SFTP connection using the SSH key pair generator. To do so, select Tools > SSH Keypair Generator and enter the following:

- **Key type**: Select the authentication log here. You can choose either RSA or DSA.
- **Key bitcount**: Enter the desired bit count here.
- **Password**: Enter a password here.
- **Private key filename**: Enter the name of the file for the private key.
- **Public key filename**: Enter the name of the file for the public key.

**NOTE**: The advantage of using these key-based authentication systems is that you will be able to establish secure connections without having to manually type in a password in many cases.

Site Manager

Use the Site Manager to access and configure your FTP sites. This dialog window appears whenever you click Connect on the toolbar. To make changes to an existing site, select its name in the left part of the window and enter the changes in the right part.

Click Save to save changes. You are asked to confirm the changes when you close the dialog box or connect to the site. Click Cancel to undo the changes.

The toolbar in this dialog window includes the following items:

- **New Site** - Click on this icon to add a new FTP server to the list.
- **Delete** - Click on this icon to delete the selected server from the list.
- **Duplicate** - Select a server from the list on the left side and click the Duplicate button to create a copy of the selected profile.
- **Save** - Click on this icon to save the server details you entered.
- **Cancel** - Click on this icon to delete the server details you entered.
- **Export** - Click this icon to export the server list to a .csv file.
- **Import** - Click on this icon to import FTP accounts.
- **Statistics** - Click on the Statistics Active item to turn on statistics logging for the respective server. Click on View statistics to open the Site Statistics dialog window.
- **Log** - Click on the Log Active item to retain the logs for the respective server. Click on View log to display the log.
• **Backup** - Click on **My Servers** or **Common Servers** to create a backup copy of the corresponding server list.

• **Restore** - Click on **My Servers** or **Common Servers** to restore a backup copy of the corresponding server list.

**Quick connect**

Click the **Quick Connect** button on the toolbar to quickly and easily connect to an existing FTP site.

Select the FTP server you want to connect to from the drop-down list in the dialog box that opens. You may also type in a new FTP address, in which case the login will be **anonymous**.

**Disconnect**

To disconnect from a remote system, click the **Disconnect** button.

Every client logged onto a remote system (e.g., **WISE-FTP**) reduces server performance - whether data is being transferred or not. Do not stay connected to a server longer than necessary (other users will appreciate it). Some servers disconnect you automatically after a certain period of time if the client sends no commands. **WISE-FTP** can be configured to disconnect after a certain idle time.

**Restore connection**

If a connection attempt has failed, the **FTP server** might be busy. **WISE-FTP** is able to retry the connection after a certain period of time.

Open the **Preferences** dialog box and click on **Connection and Transfer**. Enter the desired value under **Wait time before reconnecting (sec.)**.

**Anonymous login**

You usually log onto an FTP server by entering a user name and password. However, many sites offer a guest login option. Key in **anonymous** as your user name and your e-mail address as a password.

FTP servers that support anonymous login usually allow users to download files to which there are no public access restrictions; e.g., shareware programs, image collections, help texts, etc. Note that there is a special etiquette for public servers:

- Do not stay connected longer than necessary so that server performance will not be reduced.
- Do not download too many files.
- Read the "readme" files found in most directories; they contain information about the directories' content.

Another characteristic of such (public) servers is that although users may view and download files, they may not upload any files.
Transfer files or directories

After you have established a connection to the server, you can start to transfer files or directories.

1. Select the files or directories you want to upload from the directory tree in the **Local System** window on the left.

2. Choose a transfer mode in the **Transfer** menu. You can select from the following modes of transfer:
   - **ASCII**: You should use ASCII mode to transfer text files (e.g., .txt, .html, .htm, .cgi).
   - **Binary**: Image files, executable files or ZIP files (.bmp, .jpg, .exe, .zip) should always be transferred using binary mode. You should also use this mode when the file type is unknown or not registered by Windows.
   - **Auto**: When this option is selected, the software checks to see if a file extension has been defined. If it has, the file will be transferred in ASCII format. If not, or if no file extension is found, the file will be transferred in binary mode. You should choose this option as your default setting!

3. Now drag and drop the desired files to the target directories in the **Remote System** window on the right. Note that this is only possible if you have checked the **Enable drag-and-drop for directories** box under **Options > Preferences: Advanced**.

   Or:

4. Select the target directories in the right window and highlight the local system files you want to upload (or vice versa). Now click the arrows between the local system and the server window to upload/download directories or files.

**NOTE**: You can synchronize the contents of a local directory with the directory selected on the server using the **Synchronize directories** item located in the **Transfer** menu. In this case, only new or revised files will be uploaded. Files with the same name will be automatically overwritten.

Transfer arrows

The two arrows on the transfer panel (center) between the **Local System** and **Remote System** areas make it easy to upload and download.

Use the arrow pointing down to download selected files or directories to your local system. If you click the right side of that button, you can choose from several options like **Upload optimized for Web** and **Upload in encrypted state**.

Use the arrow pointing up to upload selected files or directories to the remote system. If you click the right side of that button, you can choose from several options including **Download with mask** and **Download in decrypted state**.
Queue

All connections initiated by the user are listed under **Transfer progress** in the lower part of the main window until the connection is either successful or cancelled by the user. You can re-sort the individual columns by clicking on the titles. A second click undoes the re-sorting. Click on **Transfer progress** in the **View** menu to show or hide this section. In the **Preferences** dialog box under **Connection and Transfer**, you can specify the columns you want to display.

FTP log

The **FTP** protocol (File Transfer Protocol) serves as a communication interface between an FTP client (e.g., **WISE-FTP** on your local system) and an **FTP server**. Click [here](#) for further details.

Transfer modes

Files can be transferred in two different modes: **ASCII** or **binary**. In auto mode, the transfer mode for listed file types is predefined.

Auto mode

When **Auto** is activated, **WISE-FTP** checks to see if the file extension is listed under **Preferences: File types**.

- If it is listed, the file is transferred in ASCII mode.
- If the file extension is not listed or if the file has no extension, the file is transferred in binary mode.

When **Auto** is deactivated, the file is transferred in the selected mode (binary or ASCII). Select the transfer mode of your choice in the **Transfer** menu.

ASCII mode

Use **ASCII mode** to transfer text files (e.g., .txt, .html, .htm, .cgi). The end-of-line character depends on the computer configuration. Use **ASCII mode** to ensure end-of-line characters are decoded correctly. Under **Options/File types**, you can specify file extensions to define which files are to be treated as ASCII files.

**TIP:** If you are sure that the local and remote systems are using the same operating system, you can disregard **ASCII mode** and always transfer in binary mode.

**CAUTION:** Transferring a binary file in ASCII mode may damage the file.

Binary mode

Use **binary mode** to transfer files that are not pure text files (e.g., .txt, .html, .htm, .cgi). Executable programs, word-processing documents, databases, image and audio files (.bmp, .jpg, .exe, .zip etc.) are only a few examples of files that have to be transferred in **binary mode**.
This mode should also be used for unknown file types, or those with extensions that are not registered by Windows.

**TIP:** If you are sure that the local and remote systems are using the same operating system, you can transfer in **binary mode** exclusively.

### Transfer protocol

The FTP protocol (File Transfer Protocol) serves as a communication interface between an FTP client (e.g., WISE-FTP on your local system) and an FTP server. The communication is based on predefined FTP commands (from the client) and server "replies". You do not have to know anything about this "language" to understand WISE-FTP! All menu options, dialog box prompts and mouse movements (drag-and-drop) are "translated" automatically, and server replies are processed correctly.

Whenever the program runs, the log is displayed below the main menu bar. Select or unselect **FTP Log** in the **View** menu to show or hide the log. If you are interested in the way the protocol works or need to correct mistakes, you can save the log in a text file. The log window is cleared whenever the program starts; make sure you save the log before exiting WISE-FTP.

To save the log, select **Save log as text file** from the **Tools** menu.

### Passive transfer

In passive mode, the client initiates the connection to the server to avoid problems with firewalls. In passive mode FTP, the client opens two unprivileged ports locally (N> 1024 and N+1). The first port contacts the server on port 21, but instead of then sending a PORT command and allowing the server to connect back to its data port, the client sends the PASV command. As a result, the server opens an unprivileged port (P>1024) and sends the PORT P command back to the client. The client then initiates the connection from port N+1 to port P on the server to transfer data.

### Using passive transfer

When connecting to FTP sites, the connection to your computer (the client) is normally established by the site. However, some FTP sites allow a passive transfer, where your computer establishes the connection. WISE-FTP uses the passive mode by default. Always use passive mode for transfers from and to FTP sites that support this mode.

Use of the passive mode is an absolute must in the following situations:

- When using firewalls that rely on routers
- For networks that only allow passive transfers
- When using proxy servers

Check the **Passive** box in the **Site Manager** window to enable transfers using passive mode.

### Mask for download

Use this form to download several files of the same file type from the current directory on the FTP server. Example: enter "*.gif" to download all gif files from the current directory.
Select the **Search directories** option to search through all subdirectories and to delete matching files found there.

**Encryption settings**

**WISE-FTP** supports several encryption algorithms for encryption and decryption before and after file transfer:
- RijnDael 128-bit
- RijnDael 192-bit
- RijnDael 256-bit
- BlowFish
- TripleDES

Click upload encrypted and use this dialog box to specify the default encryption method and password.

**Upload optimized for web**

With the option **Upload optimized for Web** you can significantly reduce the size of HTML, CSS and similar files before uploading them to a hosting server. That way your websites will load faster which improves the usability for visitors of your site. The content or quality of your files will not be affected.

You find the option **Upload optimized for Web** if you click the right side of the transfer arrow for upload between the local and remote windows in the main screen of WISE-FTP. Alternatively, you can go to the **Transfer** menu and select Upload file -> Upload optimized for web.

**Manage files and folders**

**Properties**

Clicking the **Properties** button opens the Properties dialog window, where you can view detailed file information; e. g., file attributes or read and write permissions. You may modify the access rights to files and directories on a UNIX FTP server, provided you have the necessary authorization.

**View file**

To view the contents of a file, select the file and click on the **Quick View** button or select the respective command from the context menu.

The file content will be displayed, either by the internal viewer or by the Windows program registered for the file type.

If the **Use internal viewer/editor by default** checkbox under **Preferences**: **General** is enabled, all file types defined as text files under **Preferences** > **File types** will be displayed using **Wise-FTP's** internal viewer.

If the **Use internal viewer/editor by default** checkbox under **Preferences**: **General** is not enabled, **WISE-FTP** will always use the Windows program registered for this file type.
NOTE: All files viewed using Quick View will be saved by default in the subfolder C:\Documents and settings\User name\Application data\AceBIT\WISE-FTP 9\QuickView (Windows XP) or C:\Users\User name\AppData\Roaming\AceBIT\WISE-FTP 9\QuickView (Windows Vista and 7), or in the folder specified under Preferences: General > Safe Quick View files in. Do not hesitate to empty this folder at any time to free up disk space.

Quick View

This program feature enables you to view file contents. File contents are viewed using either the integrated viewer or the program registered by Windows for the particular file type.

- If the Use internal viewer/editor as default box under Preferences: General is checked, all file types that have been defined as text files under Preferences: File types will be opened using the integrated WISE-FTP viewer. All other files will be opened by the program registered by Windows for the particular file type.

- If the Use internal viewer/editor as default box under Preferences: General is not checked, all files will be opened by the program registered by Windows for the particular file type.

NOTE: All files that are viewed using Quick View are saved in the Quickview sub-directory in the WISE-FTP program directory. You can delete the contents of this directory to free up disk space at any time.

Editor

WISE-FTP provides an integrated editor very well suited for viewing and editing HTML and other text files. The editor is particularly helpful when you wish to apply minor changes to documents on a remote server.

Within the editor, you can toggle between two tabs identified by text labels at the bottom of the editor window, just over the status bar. The Preview tab displays the HTML document in an HTML browser.

A special feature of the editor is the optional syntax highlighting which improves the readability of HTML documents. You can enable or disable syntax highlighting under Preferences: General.

To open text files from WISE-FTP using the application registered in Windows for the respective file type instead of the internal editor, choose Preferences: General and disable the option Use internal viewer/editor as default.

The following hot keys are available for editing:

- F1 - Help
- CTRL + O - Open an existing document file
- CTRL + P - Print the active document
- CTRL + X - Cut text from the active document to the clipboard
- CTRL + C - Copy text from the active document to the clipboard
- CTRL + V - Paste text from the clipboard into the active document
• CTRL + A - Select all text in the active document
• CTRL + Z - Undo last action, if possible
• CTRL + Y - Reverse last Undo action, if possible
• CTRL + F - Find a character string
• F3 - Repeat last find operation towards the end of the file
• CTRL + R - Find and replace a character string with another
• INS - Toggle insert/overtype mode
• CTRL + Up arrow - Scroll up one line keeping cursor in view
• CTRL + Down arrow - Scroll down one line keeping cursor in view
• CTRL + Right arrow - Move cursor to the next word
• CTRL + Left arrow - Move cursor to the preceding word

Display filter

The display filter enables you to filter the files and directories that are displayed. This can be useful for finding a particular file type of file in a directory that contains a large number of files. The filter settings allow you to choose either a particular type of file to show, or a particular type of file to hide.

For example, to display all files that have an .htm and .txt extension, right-click on the display, click Filter and enter "*.htm;*.txt" in the Mask for files to be shown field.

Sort files and folders

Sort listed files and folders by clicking on the column titles (name, date, size). Click on the column titles, Name, Size or Date to sort the list according to the respective heading. Click again to return the original sort order.

Move files

When you move a file, WISE-FTP copies it to the target directory and deletes the original file from the source directory.

You may move files between remote directories, if you have the necessary access rights.

To move a file, select one of the following methods:

1. Select the file and drag-and-drop it to the target directory. The directory must be on the same server.
2. Right-click on the selected file and choose Move to... from the pop-up menu.

Select the directory to which you want to move the file.

Move directories

When you move a sub-directory, WISE-FTP copies it to the target directory and deletes the original sub-directory in the source directory.
You may move sub-directories between remote directories, if you have the necessary access rights. To move a sub-directory, proceed as follows:

1. Drag the sub-directory and drop (drag-and-drop) it into the target directory. The directory must be on the same server.
Or:
2. Right-click the sub-directory you want to move and choose Move directory to... from the pop-up menu.
Select the directory to which you want to move the sub-directory.

Renaming files or directories

Use the Rename button to change file or directory names on the local or remote system. This feature is only available for sites to which you have the necessary access rights.

1. Select the file or directory to be renamed.
2. From the Commands menu, select Rename.
3. Enter a new name and confirm by clicking OK.

Delete files

Proceed as follows to delete remote files (this feature is only available if you have the necessary access rights):

1. Select the item.
2. Then click the Delete button.

Alternatively, you may use the context menu for this purpose: Right-click on the object to be deleted and choose Delete from the context menu.

Deletion mask

Use this form to delete several files of the same file type from the current directory on the FTP server.
Example: enter ".*" to delete all gif files from the directory.
Select the Search directories option to search through all subdirectories and to delete matching files found there.

Find file on FTP server

This dialog window enables you to search for a file on the FTP server.
In the Enter name of file or mask to search for field, you may enter the name of the file you want to find or use wildcards to filter the search; e.g., myfil.*.
You can set additional search parameters in the Search options area.
The search results will be displayed in the Found files and folders dialog window.
Directory content

Displays the contents of the active FTP directory as text so that you can copy or print the list, for example. **Access rights** for all files are also listed.

To view the directory content, proceed as follows:

1. Select a directory on the ftp server.
2. Right-click on the selected directory to open the pop-up menu.
3. Select **Directory content**.

Printing directory contents

In this section we explain how to print the contents of a directory:

1. Select a directory and choose **Directory content** from the **Commands** menu.
2. The contents of the directory will be displayed.
3. Save the contents of the directory in a text file or copy them to the clipboard.
4. You can then print the text file or paste the contents to another program (e.g., Word).

Create new directory

If you have the necessary **access rights**, you may create a new directory on the FTP server.

- From the **Commands** menu, select **New directory** and enter a name.
  
  Or:

- Right-click on the upper directory tree in the Remote System and select **New directory** from the pop-up menu.

Rename directory

Renames directories on the local or the remote system. This feature is only available for sites to which you have the necessary **access rights**.

1. Select the directory to be renamed.
2. From the **Commands** menu, select **Rename directory**, or click the icon on the toolbar.
3. Enter a new name and confirm by clicking **OK**.

Delete directory

You may only delete directories on the FTP server if you have the necessary **access rights**. To delete a folder, proceed as follows:

1. Select a directory and choose **Delete Directory** from the **Commands** menu.
2. If no folder has been selected when you click **Delete Directory**, you are prompted to enter a folder name.
If a folder contains files, you may only delete it if the Allow deletion of non-empty folders box under the Advanced tab in the Preferences dialog box has been checked.

Delete directories containing files

An empty directory may be deleted at any time. Do the following to delete a directory that is not empty:

1. Open the Preferences dialog box.
2. Select the Advanced tab.
3. Check the Allow deletion of non-empty directories box under Additional.

Directory synchronization

The Synchronize directories option enables you to synchronize directories on your local system with those on the remote system. This can be helpful if you have edited local files and you do not want to upload them individually.

Enter the options for directory synchronization. These options enable you to synchronize local directories with those on the remote system.

**Synchronization rules**

- **By filename**: When this option is checked, the synchronization operation disregards the case of the files names.
- **By date/time**: When this option is checked, files are checked by date and time stamp.
- **By file size**: When this option is checked, files are checked according to size, and the larger file is used.

**Note**: Synchronizing based on date/time or file size often produces erroneous results on UNIX servers! This is because the server uses the server date for uploaded files, which may be different from file's date. In addition, file sizes on Windows and UNIX systems are different.

- **Recurse sub-directories**: When this option is checked, WISE-FTP also searches through sub-directories for changed files.

Mirroring

The Mirror feature enables you to mirror your directories on either an FTP server or your local system.

Select the appropriate setting: **On FTP site** or **On local system**.

Drag-and-drop

Use the well-known Windows drag-and-drop feature to transfer files and directories. Make sure drag-and-drop is enabled in the Preferences dialog box. From the Options menu in the main window, choose Preferences > Advanced. Check the Enable drag-and-drop for directories box.
This enables you to:

- Drag files and directories from the left (local) part of the main window to the right (remote).
- Drag files and directories from your desktop or any other window to the server.
- Right-click a remote file to open the pop-up menu.

**Change file access rights on a UNIX server**

Select the file(s) you want changed. From the "Commands" menu, select "Properties". Access rights are defined by three digits; for example, 644 are the digits for the rights described above. The first digit represents the rights of the owner, the second the rights of group members and the third the rights of all other users. The three digits are used in the WISE-FTP log and by some system administrators and Internet providers. The following table shows the rights that correspond to the respective digits. The third column gives possible values for owners, groups and other users as they are displayed in the ten-digit file list on a UNIX server. To view this file list, select Directory content.

<table>
<thead>
<tr>
<th>Selected right</th>
<th>1st, 2nd, or 3rd digit</th>
<th>Rights as per file list</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>0</td>
<td>--</td>
</tr>
<tr>
<td>Execute</td>
<td>1</td>
<td>--x</td>
</tr>
<tr>
<td>Write</td>
<td>2</td>
<td>-w-</td>
</tr>
<tr>
<td>Write, Execute</td>
<td>3</td>
<td>-wx</td>
</tr>
<tr>
<td>Read</td>
<td>4</td>
<td>r--</td>
</tr>
<tr>
<td>Read, Execute</td>
<td>5</td>
<td>r-x</td>
</tr>
<tr>
<td>Read, Write</td>
<td>6</td>
<td>rw-</td>
</tr>
<tr>
<td>Read, Write, Execute</td>
<td>7</td>
<td>rwx</td>
</tr>
</tbody>
</table>

**Manage sites**

**Rename existing site**

Ideally, a site's profile name describes its content and the topic. To rename an existing site, proceed as follows:

1. From the Tools menu, open Site Manager.
2. Select the site to be renamed.
3. Enter a new name under Profile name. You are asked to confirm the changes when you close the dialog box or connect to the site.

**Add comments to existing site**

Comments can be added to every existing FTP site. This helps you keep track, especially when you have a large number of sites.
How to add comments to existing sites:

1. Open the Site Manager by clicking on **Tools** > **Site Manager**.
2. Select the site you want to add comments to.
3. Click on the **Advanced** tab.
4. Add comments under **Comments**.

Create new directory for existing site

1. From the **Tools** menu, open **Site Manager**.
2. Click the down arrow beside **New Site** and select **New directory** from the drop-down menu.
3. Enter a name for a new directory.

**TIP**: To create a new FTP site in a particular directory, make sure the directory is selected first.

Administer and sort existing sites into different folders

**WISE-FTP** allows you to sort existing sites into directories that have been assigned distinct names. This simplifies site management (especially as the number of saved sites increases over time). It may be helpful to arrange sites in directories according to different topics; e.g., one directory for sites offering free games, one for software updates, etc.

From the **Tools** menu, open **Site Manager**. You may use **drag-and-drop**, as you would in Windows Explorer. Direct your mouse pointer to the desired object, then press and hold the left mouse button and drag the file to the desired directory.

Delete existing site

Delete existing sites as follows:

1. From the **Tools** menu, open **Site Manager**.
2. Select the site or directory to be removed and click the **Delete** icon.

Export server list

Use the export feature to export the details of the server you use to a CSV file. Choose the **Export** icon from the **Site Manager** toolbar. Choose the **Export** item to export all servers included in the list or **Export selected** to export only those servers that have been selected. In the next window, enter the file name for the CSV file to which the data is to be exported and click on **Save**.

Importing FTP accounts

**Import account**

**WISE-FTP** can automatically import the FTP server connection data from your provider.
Simply enter your customer number or domain name and your password.

**NOTE:** This feature is currently only provided by 1&1 and Schlund+Partner.

### File import

You can also import the connection data from another **WISE-FTP** installation. Simply select the `wiseftpsrvs.ini` file from the other **WISE-FTP** installation's program directory.

### Server statistics

Server statistics is a very useful tool that enables you to analyze how the FTP server is being utilized.

The **Server statistics** dialog box provides detailed information on the utilization of a server. In the top section you will find a table with a summary. In the lower section of the dialog box you will find a graphical representation of the utilization data.

**NOTE:** The statistics are disabled by default. To be able to use them, you first have to check the **Statistics active** option in the **Site Manager** dialog box.

### Favorites

**WISE-FTP** allows you to create and manage favorites. Frequently used sites do thus not need to be opened via the **Site Manager**, but can be opened directly from the Favorites menu or the favorites toolbar.

To add the site you are currently visiting to your favorites, select **Favorites** from the menu bar, then click **Add to favorites**. Click **Manage favorites** to organize your favorites at any time.

#### Add to favorites

To add the current open connection to your list of favorites click **Add to favorites**... in the **Favorites** menu.

Enter a name for the connection with which you can identify your connection later.

Then choose a folder to which to add it to. If you would like to create a completely new folder click **New Folder** and enter the name of the new folder.

If you add a connection to the **Favorites Menu** or a subfolder of the Favorites Menu, your favorite connection will be shown when you go to the Favorites menu and can be selected from there.

If you add a connection to the **Favorites Toolbar** or a subfolder of the Favorites Menu, your favorite connection will appear in the toolbar below the default toolbar and can be opened from there.

#### Manage favorites

You may edit and organize your favorites at any time. Choose **Manage Favorites** from the **Favorites** menu. There are three kinds of storage possibilities for your favorites: Recent Connections, the Favorites Menu and the Favorites Toolbar.

- To add a new folder to the Favorites menu or toolbar, click **New Folder**.
- In addition, you can **Rename** or **Delete** a folder or connection of your choice.
• To change the order of the items in a list, click **Move Up/Down**. Alternatively, you can drag & drop the items of a list to the position you want.
• To create a backup of your favorite list, click **Backup**.
• Via the **Restore** button you can use a favorites list which you created and saved before.
• Select a connection from the list to see the server address and the last access to the site.

**Macros**

**WISE-FTP**’s macro functionality enables you to record frequently performed actions and run them subsequently as often as you wish.
Macro recording can be used for the following commands:
• Establish a remote connection via an existing site profile
• File download
• File upload
• Directory download
• Directory upload
• Rename a file or Directory on a server
• Close a remote connection

To record a macro, open the **Tools** menu and click **Macro** and then **Start recording**, or click the corresponding icon on the toolbar.

**Note:** You need to enable the **Macro** option in the **View > Toolbars** menu in order to make the Macro toolbar visible.

The macros created in **WISE-FTP** are stored in the script language VBScript with the file extension ".vbs". VBScript files are mere text files and can be edited in any text editor. To edit a script using the internal editor, open the **Tools** menu and choose the **Macro** option and then **Open script**.

To run a macro, open the **Tools** menu, choose the **Macro** option and then **Run script**, or click the corresponding icon on the toolbar. Alternatively, you may run a macro by double-clicking the respective vbs file in Windows Explorer.

**Start recording**

Use the **Start recording** command to start recording a **macro**.

See also: **Macros**

**Stop recording**

The **Stop recording** command stops a currently active recording and prompts you to save the **macro** as a vbs file.

See also: **Macros**
Run script

Use the **Run script** command to open a dialog box prompting you to select a vbs file. If you choose a valid **WISE-FTP** macro, it will be run immediately.

See also: Macros

Open script

Use the **Open script** command to open an existing macro in the internal editor.

See also: Macros

**WISE-FTP Task Planner**

**WISE-FTP's Task Planner** facilitates the automation of file uploads and downloads as well as automated directory synchronization. It runs as a Windows service which means that it works in background, does not require a user to be logged on, and consumes a minimum of system resources. You can start, stop, pause or continue the service in the **Task Planner** menu. To schedule a new task, go to the **Task Planner** menu and click on the **Create new task** icon. This opens the **WISE-FTP Schedule Wizard**, which will guide you through the three steps of creating a new task.

**Step 1**

First, enter an existing **WISE-FTP** server profile into the **Profile name** field. To do so, click on the **Select/Edit** button and select a remote server in the **Site Manager** dialog box. Next, choose the type of task to be performed. The following options are available:

- Download a file from an FTP server
- Download a directory (and its contents) from an FTP server
- Upload a local file to an FTP server
- Upload a local folder (and its contents) to an FTP server
- Synchronize a directory on an FTP server with a local folder

**Step 2**

Now enter a **Local name**. Depending on the task chosen in Step 1, you have to specify either a directory or a filename in this field. In the **Name on server** field, specify a directory or filename on the server, as appropriate.

**Step 3**

As the last step, specify when and how many times the task shall be performed. You can also choose to have an e-mail notification sent when the task has been completed.

**NOTE:** You can change the settings for a planned task at any time by opening the Task Planer tab at the bottom of the main window. Here, you can double-click a planned task or right-click it to choose from the available options (delete, modify etc.).
Task Planner options
You can adjust the Task Planner settings from the options window. The options dialog window has the following tabs:

- **General**
- **Logging**
- **E-mail Settings**
- **Default**

Options: General
This is where you set the options for the application:

- **Run at Windows startup**: Check this box if you want the WISE-FTP Task Planner to run automatically every time Windows starts.
- **"Close" button minimizes application**: Selecting this check box causes the Task Planner to be minimized instead of closed when you exit the program using the "x" in the upper right corner of the dialog window.
- **File name**: Enter the path to the task list here.
- **Automatically save queue every: ... minutes**: Select this option and enter a specific number of minutes to save the queue at the specified intervals.
- **Create backup copy**: Check this box to automatically back up the task list.
- **User interface language**: Here is where you select the user interface language. German, English, Spanish and French are presently available.

Options: Logging
Here is where you adjust the settings for the log file:

- **Save log in the file**: When you check this box, the log will be saved under the file name you have specified in "Filename".
- **Filename**: Enter the name of the file for the log here.
- **Max size (Kb)**: Enter the maximum size of the log file in kilobytes here.

Options: E-mail Settings
The WISE-FTP Task Planner can inform you via e-mail on the completion status of auto-scheduled operations.
This can be helpful to keep you informed on the status of an operation although it may be have been carried out on another computer or at a time when you were not present at your computer.
Options: Default
Enter the default settings for the planned tasks here:
- **Username**: Enter your user name here.
- **Password**: Enter the corresponding password here.
- **Type**: Select whether to upload or download the files.
- **Schedule**: Select how often the task is to be executed.
- **Delete task after completion**: Check this box to delete the task after it has been completed.
Settings and Commands

Preferences

Customize wise-ftp to suit the configuration of your system. There are the following 5 tabs in the Preferences menu:

• General
• Advanced
• Connection and Transfer
• Network Settings
• File types

Preferences: General

You can adjust the following settings under the General tab in the Options > Preferences dialog window.

Appearance

• Colored rows in FTP log: Check this box to display log messages in different colors.
• Syntax highlighting: If this box is checked, HTML source code in the internal editor is shown in different colors to make working with the code easier.
• User interface language: Select the language you want to use in the program. Available options are English, German, French and Spanish. The feature changes the display language for menu options, messages, etc. Of course, it does not affect how the program works.
• Theme of user interface: Choose a theme for the display of the program interface.

Behavior

• Program Startup mode: Define here in which mode WISE-FTP should be started. For example, you can restore the connections which were open when you previously used the program or automatically open the Connect dialog on startup.
• Hide password in log: Check this box to mask passwords in the log to ensure that your passwords are not visible in the log.
• Use internal viewer/editor as the default: When this box is checked, Quick View uses WISE-FTP’s internal viewer to display files. If it is not checked, Quick View will open files using the program registered for this file type by Windows.
• Save Quick View files in: Select a directory in which to temporarily store the files you are viewing with Quick View.
• Disk space to use for Quick View files: Specify the maximum disk space to use for storing the Quick View files.
- **Automatically check for updates every n days**: Enable this checkbox and enter a time interval in days if you want WISE-FTP to automatically search for new versions. If you disable this option, you should call up the Update Manager via **File/Update Manager** at regular intervals in order to search for new versions manually.

- **No sounds**: Uncheck this box to assign sounds to particular events.

- **Double-click action**: Select what the software should do if you double-click a file or a directory.

### Preferences: Advanced
You can adjust the following settings on the Advanced tab in the **Options > Preferences** dialog window.

#### Additional
- **Delete completed transfers from queue**: All connections initiated by the user are listed under "Transfer Progress" in the lower part of the main window. When this box is checked, all successfully completed transfers are deleted from the list.

- **Maintain connection at "idle"**: When WISE-FTP has not sent any commands to the server for a pre-defined length of time, the program will disconnect automatically, because every user logged onto a remote system reduces server performance - whether data is being transferred or not. Check this box to maintain the connection. Note that some servers are configured to disconnect at idle, so a server may close the connection even though you have checked this box.

- **Monitor clipboard for FTP URLs**: If this option is checked, any FTP URL (e. g., ftp://myserver.com) on the clipboard will be automatically inserted into the quick connection.

- **Read all directories when connecting**: When this box is checked, the contents of all directories on the FTP server will be read completely when connected. This may take some time. If the box is not checked, only selected directories will be read.

- **Use multiple connections interface**: WISE-FTP is able to connect to multiple FTP servers at the same time. If you wish to use this feature, you need to enable the Use multiple connections interface checkbox. Enabling this option will modify the user interface slightly to display the individual FTP servers to which you are logged on as tabs in the FTP Servers section.

- **Preserve file date when downloading**: Every new file is stored with a creation date. When new files are downloaded to your local system, the file date updates to the date the
file was downloaded. When this box is checked, the date for downloaded files does not change.

- **Preserve file date when uploading**: Every new file is stored with a creation date. When new files are uploaded to a server, the file date updates to the date the file was uploaded. When this box is checked, the date for uploaded files does not change.

- **Confirm overwriting of identical/newer files**: When this box is checked, WISE-FTP will display a warning message - and give you an opportunity to cancel this operation - before deleting identical or newer files.

- **Transfer only newer files at directory transfer**: When you upload a directory and a remote directory with the same name already exists, the files in the directory on the server are usually overwritten. When this box is checked, only new files will be uploaded into the directory. Files with the same name will be overwritten if the ones uploaded are newer.

- **Allow deletion of non-empty directories**: This enables you to delete a directory and its entire contents from an FTP site, provided you have the necessary access rights.

- **Enable moving directories on server with drag-and-drop**: This option enables you to drag-and-drop directories on the remote system.

### Default Settings

- **Default compression**: WISE-FTP supports the zip, gz, tar, tar.gz, and cab compression methods. Choose a compression method to use for compressed transfer.

- **Default password**: You may enter a different e-mail address, for example, which will be used as the default password for anonymous logins. This is common practice on most FTP servers allowing anonymous logins.

- **Default FTP port**: Only advanced users should change the default setting; it is usually "21" or "ftp".

- **Use Passive Mode by default**: Enable this option to make WISE-FTP select the Passive mode on creating new FTP sites. You can set this option individually in each FTP profile.

- **Default action if file exists**: Here you can select an action which will always be used once a file is up- or downloaded, while a file with the same name already exists on the target location. For example you can overwrite the existing file if the copied file is newer or you can resume the transfer of two identical files (this is mostly only supported by LINUX/UNIX servers). By default, a dialog will be shown which allows you to choose the according action for every single file.
Preferences: Connection and Transfer
You can adjust the following settings under the Connection and Transfer tab in the Options > Preferences dialog window.

Connection
- Connection timeout (sec.): Period of time during which WISE-FTP tries to connect to a remote system. The connection attempt is cancelled when the time runs out.
- Connection attempts: Enter how many times WISE-FTP should retry to establish a connection if the first connection attempt fails.
- Wait time before reconnecting (sec.): The period of time WISE-FTP waits between a failed connection and the next connection attempt.
- Automatically Dial-Up using default connection: This option allows you to establish dial-up connections automatically.
- Terminate Dial-Up connection on exit: A Dial-Up connection will automatically be closed as soon as you close the program.
- Use ports range: This setting should only be changed by experienced users and allows you to limit the range of ports used by WISE-FTP.

Transfers
- Transfer attempts: Enter how many times WISE-FTP should retry to transfer a file if the first transfer attempt fails.
- Max threads: Select how many files are to be transferred at the same time. The maximum value is ten simultaneous transfers.
- Warn on view if file larger than (KB): A warning message will be displayed if you want to view a remote file larger than this setting.
- Change filename on transfer: Use this setting to define how WISE-FTP should change filenames during upload to a server. The available options are "Don't change", "UPPER CASE", and "lower case".
- Auto-resume interrupted transfers: Selects whether or not to resume interrupted transfers automatically.
- Limit transfer speed: Allows you to limit the transfer rate. This can be useful if WISE-FTP should not use the entire bandwidth of the Internet connection in order to allow other applications (or other network users) to use the shared Internet connection at an adequate speed.
- Use multi-part downloads: Determines whether files should be downloaded in several parts. Define a minimum file size for multi-part downloads and the number of parts into which the file is to be divided. This may help to reduce the number of repetitions for
large files and/or very poor connections, since failures will not require the whole file to be downloaded again, but only the defective part of the file.

Preferences: Network Settings
If you are using a Proxy server, you can configure the program accordingly in the Network Settings dialog box.
In some network environments, the local network is separated from the rest of the Internet by a firewall. If your network is firewall-protected and blocks the FTP transfers, you can specify the respective firewall parameters to ensure that FTP transfers will be allowed to "pass through" the firewall. For this purpose, you require information on the implemented firewall (host name and/or IP address) from your network administrator.
Proceed as follows to configure proxy settings for FTP and HTTP connections:

- From the Connection Type drop-down menu, choose the type of proxy server you are using. Your system administrator can tell you which proxy you are using.
- Enter your proxy parameters like user name and password.

Preferences: File types
WISE-FTP lets you define the transfer mode to be used with different file types. When the transfer mode in the main window is set to Auto, files are transferred in binary mode unless the file name includes an extension that is listed under File types in the Preferences window. If the file extension is listed here, the transfer takes place in ASCII mode. The extensions of all files that will be transferred in ASCII mode when the transfer mode is set to Auto are listed.

Adding a file extension to the list:
1. Enter the desired file extension under: Always use ASCII mode for files with these extensions. The extension may have up to nine characters, including dots.
2. Click Add. The file extension will appear in the list box on the left.
3. To remove an extension from the list, select it and click Remove.

NOTE: The file types listed here are regarded as text files by the internal editor and are available for editing.

Configuration wizard
The Configuration wizard enables you to configure WISE-FTP. Experienced users may configure WISE-FTP using the Preferences item in the Options menu. The Configuration wizard opens when the application starts for the first time. To reopen the wizard again later, choose Configuration wizard from the Options menu. The wizard guides you through the settings step by step. If you are not sure which settings to use, use the default values.

Configuration wizard: Step 1
In step 1 of the wizard, you adjust the following user interface settings:
- **User interface language**: Select the language you want to use in the program. Available options are English, German, Spanish and French. The feature changes the display language for menu options, messages, etc. Of course, it does not affect how the program works.

- **Program Startup mode**: Define here in which mode WISE-FTP should be started. For example, you can restore the connections which were open when you previously used the program or automatically open the Connect dialog on startup.

- **Colored rows in FTP log**: Check this box to display log messages in different colors.

- **Hide password in log**: Check this box to mask passwords in the log and ensure that your passwords are not visible in the log.

- **Use multiple connections interface**: This functionality allows you to log in to two or more FTP servers at the same time. The servers to which you are connected will be displayed as tabs in the FTP Server section.

**Configuration wizard: Step 2**

In the step 2 of the wizard, you make general settings and adjust WISE-FTP according to your own needs:

- **E-mail address**: Type in your e-mail address. It is used as the standard password for anonymous access. This is common with most FTP servers that allow anonymous access.

- **Use internal viewer /editor as the default**: When this box is checked, Quick View uses WISE-FTP's internal viewer to display files. If it is not checked, Quick View will open files using the program registered for this file type by Windows.

- **Enable drag-and-drop for folders**: This option enables you to drag-and-drop files and directories between the local and remote system.

- **Preserve file date when downloading**: Every new file is stored with a creation date. When new files are downloaded to your local system, the file date updates to the date it was downloaded. When this box is checked, the date for downloaded files does not change.

- **Preserve file date when uploading**: Every new file is stored with a creation date. When new files are uploaded to a server, the file date updates to the date the file was uploaded. When this box is checked, the date for uploaded files does not change.

- **Allow deletion of non-empty folders**: This enables you to delete a directory and its entire contents from an FTP site, provided you have the necessary access rights.
• **Transfer only newer files at folder transfer**: When you upload a directory and a remote directory with the same name already exists, the files in the directory on the server are usually overwritten. When this box is checked, only new files will be uploaded into the directory. Files with the same name will be overwritten if the ones uploaded are newer.

• **Confirm overwriting of identical/newer files**: When this box is checked, WISE-FTP will display a warning message - and an opportunity to cancel this operation - before deleting identical or newer files.

• **Monitor clipboard for FTP URLs**: When this option is checked, the FTP URL (e.g., ftp://myserver.com) is automatically inserted into the quick connection if there is a URL on the clipboard.

### Configuration wizard: Step 3
In step 3 of the wizard, you can change the connection settings:

• **Default FTP port**: Only advanced users should change the default setting; it is usually "21" or "ftp".

• **Use Passive Mode by default**: Choose this option to always use Passive transfer.

• **Connection attempts**: Enter how many times WISE-FTP should retry to establish a connection if the first connection attempt fails.

• **Connection timeout (sec.)**: Connection timeout is the period of time within which WISE-FTP tries to connect to a remote system. The connection attempt is cancelled when the time runs out.

• **Transfer attempts**: Enter how many times WISE-FTP should retry to transfer a file if the first transfer attempt fails.

• **Wait time before reconnecting (sec.)**: The period of time WISE-FTP waits between a failed connection and the next connection attempt.

• **Max threads**: Select how many files are to be transferred at the same time. The maximum value is ten simultaneous transfers.

• **Auto-resume interrupted transfers**: Selects whether to resume interrupted transfers automatically.

### Configuration wizard: Step 4
In step four of the wizard, you can change the proxy settings for WISE-FTP. Enter the proxy settings for FTP, SFTP and the Update Manager separately.
Under **Type**, select your proxy server type. If you have chosen **FTP** and **SFTP**, you may only select **FTP** or **SOCKS**. For the Update Manager, you can choose either **http** or **SOCKS**. If you select **SOCKS**, your proxy server must be running SOCKS. There are different SOCKS types. You can select the one that applies under **SOCKS Proxy type**. Contact your system administrator to find out which proxy you use.

**Configuration wizard: Step 5**
The wizard has completed the configuration of **WISE-FTP**. Click **Close** to exit the wizard.

**Customize keyboard**

**WISE-FTP** enables you to choose your own shortcuts for the most important program features to make the program quicker and easier to use. To create customized shortcuts, proceed as follows:
1. From the **Options** menu, select **Shortcut keys** to open the **Set shortcut keys** dialog box.
2. Select a menu or other item from the **Categories** list.
3. The corresponding functions will be displayed in the **Commands** list.
4. Select a function from the **Commands** list to display a corresponding description in the **Description** section below. The **Current shortcut key** field shows the present shortcut for the list item, if one exists.
5. If you wish to replace the current shortcut key combination by a new one, click the **Remove** button. Enter the new shortcut key combination in the **New shortcut key** field by actually pressing the respective key combination on the keyboard.
6. Then click **Assign** to assign the shortcut to the function.
7. Click **OK** to close the dialog box.

**TIP:** You can save and load your shortcut keys. To do so, click on the buttons named accordingly in right section of the **Set shortcut keys** dialog box. If you are running **WISE-FTP** on several computers or set up your computer anew, it can be helpful to be able to fall back on saved shortcut keys.

**Send commands directly to server**

**Custom command... option**
This feature allows advanced users to send FTP commands directly to the server. From the **Commands** menu, select **Custom command**.

**Supported FTP commands (overview)**

**WISE-FTP** enables you to send commands to an FTP server via menus, dialog boxes and mouse movements (drag-and-drop). **WISE-FTP** automatically "translates" these operations into appropriate FTP commands. Users do not need to know anything about the FTP protocol.
Advanced users may sometimes want to type in these commands themselves. The File Transfer Protocol comprises a total of about thirty-five FTP commands, plus new extensions. WISE-FTP supports the following ten (custom) commands:

- CHMOD
- CWD
- HELP
- LIST
- NLST
- PWD
- QUOTE
- RETR
- SITE
- STOR
- SYST

To send a custom command to a server, select Custom command from the Commands menu. To add additional Custom commands to the list, select Custom Commands from the Options menu.

Configure custom commands

In WISE-FTP you have the option to add custom command to the Command -> Custom Commands menu. This is particularly useful for service-specific commands. To add a new custom command to the list, open the Options menu and click Custom Commands. Then, click the Add button. To edit a custom command, select it in the list and click Edit. To delete a command from the list, click Delete. Use the Move Up and Move Down buttons to rearrange the entries in the command list.

Custom Command Properties

This dialog box allows you to create a new command or edit an existing one. The available fields are:

- **Title** – Name of the command as it will be displayed in the menu (optional entry).
- **Command** – FTP command (mandatory entry); enter a command or choose one from the drop-down list.
- **Parameters** – Parameters used with the command (optional entry); multiple parameters must be separated by a space. You may enter any value or parameter (see below).
- **Macros** - To enter a macro parameter in the Parameter field, select the relevant line from the Macros list and click Insert. The macro parameters have the following meanings:
  - $FILE – Will be replaced by the selected file name on the server.
  - $PATH – Will be replaced by the complete path of the current directory on the server.
  - $PROMPT – Opens a dialog box and prompts the user to enter a parameter value.
- **Hot Key** – Global key combination assigned to this command (optional entry). Place the cursor in this editing field and press the key combination you wish to assign to this command.
### Meaning of reply codes

#### Reply codes

This chapter gives an overview of the most important reply codes that might appear in the FTP log. The first digit of the three digit codes indicates one of the following: positive reply, successful operation, positive interim reply, temporary negative reply or permanent negative reply. Every reply code that may be returned is listed in the following sections. The codes are sorted by their first digit.

#### 1xx - Positive reply

The following reply codes point to a successful beginning of an action. However, the client waits for further replies before going on.

- **110** Restart marker reply
- **120** Service ready in nnn minutes
- **125** Data connection already open; transfer starting
- **150** File status okay; about to open data connection

#### 2xx - Successful operation

These reply codes hint to successful completion of an action. The client may run another command.

- **200** Command okay
- **202** Command not implemented, superfluous at this site
- **211** System status, or system help reply
- **212** Directory status.
- **213** File status
- **214** Help message
- **215** `NAME system type`, where `NAME` is an official system name from the list in the Assigned Numbers document.
- **220** Service ready for new user
- **221** Service closing control connection. Logged out if appropriate
- **225** Data connection open; no transfer in progress
- **227** Entering Passive Mode (h1,h2,h3,h4,p1,p2)
- **230** User logged in, proceed
- **250** Requested file action okay, completed
- **257** "PATHNAME" created
Meaning of reply codes

3xx - Positive interim reply

The following reply codes indicate that although the command was successfully executed, the server needs additional information about the client before it can complete the operation.

- 331: User name okay, need password
- 332: Need account for login
- 350: Requested file action pending further information

4xx - Transient negative reply

The following reply codes indicate that the command could not be executed; however, because the error message indicates a temporary problem, you may be able to successfully complete the operation if you retry.

- 421: Service unavailable, closing control connection
- 425: Can't open data connection
- 426: Connection closed, transfer aborted
- 450: Requested file action not taken. File unavailable
- 451: Requested action aborted: local error in processing
- 452: Requested action not taken. Insufficient storage space in system

5xx - Permanent negative reply

These reply codes indicate that the operation could not be completed. Since the nature of the error is permanent, you will get the same error message if you try the operation again.

- 500: Syntax error, command unrecognized
- 501: Syntax error in parameters or arguments
- 502: Command not implemented
- 503: Bad sequence of commands
- 504: Command not implemented for that parameter
- 530: Not logged in
- 532: Need account for storing files
- 550: Requested action not taken. File unavailable
- 551: Requested action aborted: page type unknown
- 552: Requested file action aborted. Exceeded storage allocation (for current directory or dataset)
- 553: Requested action not taken. File name not allowed
Frequent reply codes and causes

The following is a list of frequently occurring reply codes and possible causes:

- **150**: Two ports are used for an FTP connection: 21 to send commands and 20 to send data. This reply code indicates that the server is establishing a new connection to port 20 for the data transfer.

- **230**: This reply code indicates that the appropriate password was sent and that the user logged in successfully.

- **331**: This reply code indicates that the user name was sent. The same reply code always appears, regardless of whether the user name is valid for the system or not.

- **426**: A data connection was being established to process an operation, but the operation was aborted and the data connection closed.

- **530**: This reply code indicates that the user cannot log in because the user name and/or password entered are invalid. Your user account password could have been misspelled, or the server could be set up for anonymous access only.

- **550**: The command cannot be executed because the specified file does not exist. This reply code could indicate you are using the GET command to request a file that is not available on the system or trying to use a PUT command to create a file in a folder for which you lack the necessary write permission.

See also: [3xx - Positive interim reply](#), [4xx - Transient negative reply](#), [5xx - Permanent negative reply](#).
FTP commands

Supported FTP commands (overview)

WISE-FTP enables you to send commands to an FTP server via menus, dialog boxes and mouse movements (drag-and-drop). WISE-FTP automatically "translates" these operations into appropriate FTP commands. Users do not need to know anything about the FTP protocol. Advanced users may sometimes want to type in these commands themselves. The File Transfer Protocol comprises a total of about thirty-five FTP commands, plus new extensions. WISE-FTP supports the following ten (custom) commands:

- CHMOD
- CWD
- HELP
- LIST
- NLST
- PWD
- QUOTE
- RETR
- SITE
- STOR
- SYST

To send a custom command to a server, select Custom command from the Commands menu. To add additional Custom commands to the list, select Custom Commands from the Options menu.

FTP command: CHMOD

This command is only available on servers running UNIX and can only be used when more than one remote item is selected. You may use CHMOD to change access rights, provided you have the necessary access permissions for this server.

FTP command: CWD

CWD <SP> <pathname> <CRLF>
Enables users to change the active directory on the FTP server.

FTP command: HELP

HELP [<SP> <string>] <CRLF>
Requests a list of all valid commands from the server and transfers other system information.
FTP command: LIST

LIST [<SP> <pathname>] <CRLF>
Asks for the contents of the active directory. If <pathname> points to a directory or group of files, the server transfers a detailed list of the files in the specified directory.

FTP command: NLST

NLST [<SP> <pathname>] <CRLF>
Orders the server to send a directory list to the client.

FTP command: PWD

PWD <CRLF>
Requests that the server send back the name of the active directory.

FTP command: QUOTE

QUOTE <string> <CRLF>
FTP commands starting with QUOTE are sent to the server as they are written. This enables users to key in server-specific syntax.

FTP command: RETR

RETR <SP> <pathname> <CRLF>
Orders the server to send the file in <pathname> to the client. The file on the remote system is not modified in any way.

FTP command: SITE

SITE <SP> <string> <CRLF>
Enables user to send server-specific commands. WISE-FTP adds SITE automatically whenever a server-specific command is sent.

FTP command: STOR

STOR <SP> <pathname> <CRLF>
Orders the client to send the file in <pathname> to the server. If a file with the same name already exists, it is overwritten.

FTP command: SYST

SYST <CRLF>
Queries the operating system the server is using.
Troubleshooting

Getting help

If you need help on a particular topic, proceed as follows:

- Enter a search term in the online help index.
- For context-sensitive help, press F1 or click a Help button while working in WISE-FTP.
- Read the FAQs about WISE-FTP to find answers to frequently asked questions.
- Post your questions to WISE-FTP’s support forum (available to all users), or look for an answer to your question there.
- Contact our Support team.

TIP: Most program elements have tool tips. These are displayed automatically when the mouse pointer is hovered over the item for a few seconds.

Connection problems

<table>
<thead>
<tr>
<th>PROBLEM</th>
<th>SOLUTION</th>
</tr>
</thead>
</table>
| Error message: Unable to connect to FTP server. | • Verify that you are connected to the Internet. WISE-FTP cannot establish a dial-up connection by itself. It uses the dialer defined in the file winsock.dll (e.g., "Dial-up Network").  
  • If you are using a proxy server or a firewall, make sure they are correctly configured in the "Preferences" menu.  
  • Check your user name/password combination. |
| Remote server is suddenly disconnected. | • Some servers disconnect automatically after a certain period of time if they do not receive commands from the client. This helps avoid unnecessary reduction in server performance. The server |
never disconnects when a transfer is in progress. It only disconnects if the client and the server have not communicated for a specific period of time as defined by the server administrator.

- Another possible reason is the configuration of WISE-FTP.
  Check **Maintain connection at "idle"** under **Preferences > Advanced**.

<table>
<thead>
<tr>
<th>Error message: &quot;500 No route to host: Winsock error # 10065&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Verify that you are connected to the Internet.</td>
</tr>
<tr>
<td>• Check to see if there is a firewall that has not been set up correctly.</td>
</tr>
<tr>
<td>• Check to see if a software firewall (e. g., Norton Internet Security) is blocking access.</td>
</tr>
</tbody>
</table>

See also: Unable to connect to remote system

**Problems during file transfer**

<table>
<thead>
<tr>
<th>PROBLEM</th>
<th>SOLUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Some of the transferred files are corrupted.</td>
<td>• One reason may be that you have transferred the files in ASCII mode. This may cause errors with some file types. Only use ASCII mode to transfer plain text documents (e. g., .txt, .htm, .html, .cgi, .php). All the other files must be transferred in binary mode.</td>
</tr>
<tr>
<td></td>
<td>• If the problem persists, check that you have activated data flow control in the modem settings.</td>
</tr>
</tbody>
</table>
Click "Start"->"Settings"->"Control Panel"->"Modem".

| After the files were uploaded successfully, the website cannot be found on the Internet. | • Verify that you have uploaded the HTML document to the root directory. This directory is the uppermost directory on your webserver and appears as "/".
  • Your start file is not called index.html, or you have not used lower case for the file name.
  • Verify that you have proper access rights to the files. In WISE-FTP, you can assign access rights by right-clicking a file and selecting "Properties". For HTML documents, 644 is sufficient. |
| --- | --- |
| Error message "Error 404" | • Your startup document is not index.html or not every letter of the file name is in lower case.
  • You have saved your website or start file index.html in a sub-directory. Move the file to your webserver's root directory. In most cases, this is the uppermost directory on the FTP server. |

**Symlinks**

The FTP protocol does not allow deleting or editing symlinks. WISE-FTP can only follow symlinks. In order to edit, create or delete symlinks you need to have normal access to your Linux server via Telnet or a kind of administrative panel which your internet hosting provider may support.
# Index

<table>
<thead>
<tr>
<th>1</th>
<th>Content 25</th>
</tr>
</thead>
<tbody>
<tr>
<td>1xx - Positive reply 43</td>
<td>Create 28</td>
</tr>
<tr>
<td>2</td>
<td>directory 25</td>
</tr>
<tr>
<td>2xx - Successful operation 43</td>
<td>Create new FTP site 13</td>
</tr>
<tr>
<td>3</td>
<td>Custom 41</td>
</tr>
<tr>
<td>3xx - Positive interim reply 44</td>
<td>Custom command 46, 47</td>
</tr>
<tr>
<td>4</td>
<td>Custom Command Properties 42</td>
</tr>
<tr>
<td>4xx - Transient negative reply 44</td>
<td>Custom Commands</td>
</tr>
<tr>
<td>5</td>
<td>configure 42</td>
</tr>
<tr>
<td>5xx - Permanent negative reply 44</td>
<td>Customize keyboard 41</td>
</tr>
<tr>
<td>A</td>
<td>CWD 46</td>
</tr>
<tr>
<td>Access rights 21, 27</td>
<td>D</td>
</tr>
<tr>
<td>Address 11</td>
<td>Delete 24, 26, 28</td>
</tr>
<tr>
<td>Advanced 41</td>
<td>directory 25</td>
</tr>
<tr>
<td>Anonymous 17</td>
<td>Delete directories containing files 26</td>
</tr>
<tr>
<td>Anonymous login 17</td>
<td>Delete file 24</td>
</tr>
<tr>
<td>Anzeigen einer Datei 21</td>
<td>Deletion mask 24</td>
</tr>
<tr>
<td>ASCII 19</td>
<td>Description</td>
</tr>
<tr>
<td>ASCII mode 19</td>
<td>Site profile 27</td>
</tr>
<tr>
<td>ASCII transfer mode 19</td>
<td>Direct 41</td>
</tr>
<tr>
<td>Authentication method 15</td>
<td>Directory 18, 25, 26, 28</td>
</tr>
<tr>
<td>Auto 19</td>
<td>create 25</td>
</tr>
<tr>
<td>B</td>
<td>delete 25</td>
</tr>
<tr>
<td>Binary 19</td>
<td>Mirroring 26</td>
</tr>
<tr>
<td>Binary mode 19</td>
<td>rename 25</td>
</tr>
<tr>
<td>Binary transfer mode 19</td>
<td>Directory containing files 26</td>
</tr>
<tr>
<td>C</td>
<td>Directory content 25</td>
</tr>
<tr>
<td>Cancel 17</td>
<td>Directory contents</td>
</tr>
<tr>
<td>Certificate Information 16</td>
<td>print 25</td>
</tr>
<tr>
<td>Change name</td>
<td>Directory synchronization 26</td>
</tr>
<tr>
<td>directory 25</td>
<td>Disconnect 17</td>
</tr>
<tr>
<td>Site profile 27</td>
<td>Display 21</td>
</tr>
<tr>
<td>CHMOD 46</td>
<td>Display filter 23</td>
</tr>
<tr>
<td>Close 17</td>
<td>Download 18, 19, 26</td>
</tr>
<tr>
<td>Command 20, 41, 46, 47</td>
<td>Drag 26</td>
</tr>
<tr>
<td>Comment</td>
<td>Drag &amp; Drop 26</td>
</tr>
<tr>
<td>Site profile 27</td>
<td>Drag&amp;drop 26</td>
</tr>
<tr>
<td>Configuration 16, 34</td>
<td>Drag-and-drop 26</td>
</tr>
<tr>
<td>Configuration wizard 38</td>
<td>E</td>
</tr>
<tr>
<td>Step 1 38</td>
<td>Encryption settings 21</td>
</tr>
<tr>
<td>Step 2 39</td>
<td>Error 20</td>
</tr>
<tr>
<td>Step 3 40</td>
<td>Establish 17</td>
</tr>
<tr>
<td>Step 4 40</td>
<td>Explanation 1, 9, 12</td>
</tr>
<tr>
<td>Step 5 41</td>
<td>FTP 9</td>
</tr>
<tr>
<td>Configure Custom Commands 42</td>
<td>FTP site 11</td>
</tr>
<tr>
<td>Connect 13</td>
<td>FTPS 10</td>
</tr>
<tr>
<td>Connection 13, 16, 17, 20</td>
<td>IP address 11</td>
</tr>
<tr>
<td>Connection problems 48</td>
<td>SFTP 9</td>
</tr>
</tbody>
</table>
F
Favorites 29
Features 8, 12
File 18
File list 25
File properties 21, 27
File transfer
problems 49
File types 19
File viewer 21
Files or directories
renaming 24
Find file on FTP server 24
Fingerprints 10
Folder 18, 25, 28
Format 19
Frequent reply codes and causes 45
FTP 9, 11, 20, 28, 41, 46, 47
FTP command
CHMOD 46
CWD 46
HELP 46
LIST 47
NLST 47
PWD 46
QUOTE 47
RETR 47
SITE 47
STOR 47
SYST 47
FTP commands (overview) 41, 46
FTP log 19
FTP over SSL 10
FTP server
find file 24
FTP site 9, 11, 13, 16, 20, 27, 28
New 13
FTP 10
Functions 8, 12
G
Getting help 48
H
HELP 46
Host name 11
I
Information 21
Introduction 1, 9, 11
IP address 11
K
Key pair generator 16
Keyboard
L
LIST 47
Live Update 12
Log 19, 20
Login 13, 17
Logout 17
M
Main window 12
Manage 16, 28
Site profile 27
Manage sites 16, 27
Mask for download 20
Mirroring 26
Mouse 26
Move 23, 26
Move directories 23
Move files 23
N
New 28
directory 25
NLST 47
Non-empty 26
O
Options 34, 38
Advanced 35
Connection and Transfer 37
File types 38
General 34
Proxy Settings 38
Task Planner 32
Ordering and unlocking 12
Organize favorites 29
Overview 8, 12
P
Passive transfer 20
Password 16
Preferences
Advanced 35
Connection and Transfer 37
File types 38
General 34
Proxy Settings 38
Printing directory contents 25
Private key 15
Problems during file transfer 49
Properties 21, 27, 34
Protocol 20
Public key 15
PWD 47
Q
Queue 19
Quick connect 17
Quick view 21
Quick View 22
QUOTE 47
R
Reconnect 17
Reestablish 17
Remove 24, 26, 28
directory 25
Rename
directory 25
Site profile 27
Rename existing site 27
Renaming files or directories 24
Reply codes 43
1xx - Positive reply 43
3xx - Positive interim reply 44
4xx - Transient negative reply 44
5xx - Permanent negative reply 44
Frequent reply codes and causes 45
Repy coes
2xx - Successful operation 43
Restore connection 17
RETR 47
Retry 17
S
Safety 27
Security 27
Send commands directly to server 41
Server 9, 11, 16, 27, 41
Server statistics 29
Settings 16, 34
SFTP 9
Shortcut keys 41
SITE 28, 47
Site Manager 16
Sort 23
Sort by 23
Sort files and folders 23
SSH 10
SSH File Transfer Protocol 9
SSH key pair generator 16
STOR 47
Synchronization
directory 26
SYST 47
T
Task Planner
options 32
Task Planner options
Default 33
E-mail Settings 32
General 32
Logging 32
Timeout 17
Transfer 18, 19, 20, 23, 26
Transfer arrows 18
Transfer mode 19
Transfer modes 19
Transfer protocol 20
U
UNIX server
Change file access rights 27
Unlocking 12
Update Manager 12
Upload 18, 19, 26
User name 16
Using Passive transfer 20
V
Version
2 7
3 6
4 4
5 4
View 21
View content 25
View file 21
Viewer 21
W
What is FTP 9
What is FTPE (FTP over SSL) 10
What's new in version
2 7
3 6
4 4
5 4
WISE-FTP 1